TASK(9) | Kernel Developer's Manual | TASK(9) |
void
task_init(struct task *task, void (*fn)(struct task *));
void
task_destroy(struct task *task);
void
task_schedule(struct task *task);
void
task_done(struct task *task);
bool
task_cancel(struct task *task, kmutex_t *interlock);
bool
task_cancel_async(struct task *task);
void
task_drain(void);
Task state is stored in the struct task structure. Callers of the task abstraction must allocate memory for struct task objects, but should consider them opaque, and should not inspect or copy them. Each task represented by a struct task object will be run only once at a time, until the action associated with it returns or calls task_done() to signal that it may be scheduled again.
Tasks scheduled with task_schedule() run in threads at priority PRI_NONE one at a time per CPU. Since they run one at a time, they are not allowed to sleep except on synchronization objects such as mutex(9) or rwlock(9). To run tasks at different priorities, or to allow long sleeps including memory allocation, you must use taskqueue(9) to create your own task queue.
task_init() may be used in any context, including hard interrupt context.
task_destroy() may be used in any context, including hard interrupt context.
task_schedule() may be used in any context, including hard interrupt context.
task_done() may be called only by a task's action.
The interlock is provided so that if the task's action needs it and the caller of task_cancel() holds it, then task_cancel() can release the interlock after acquiring locks internal to the task abstraction in order to avoid racing or deadlocking with the task's action. You should always assume that interlock will be released and re-acquired, and recheck any invariants you rely on it to preserve.
task_cancel_async() may be used in any context, including hard interrupt context.
Note: task_drain() does not wait for any delayed_task(9) tasks to complete.
struct mydev_softc { ... kmutex_t sc_lock; struct task sc_task; struct task *sc_contrivedtask; ... }; static void mydev_attach(device_t self, struct cfdata *match, void *aux) { struct mydev_softc *sc = device_private(self); ... task_init(&sc->sc_task, &mydev_action); sc->sc_contrivedtask = NULL; ... } static void mydev_detach(device_t self, int flags) { struct mydev_softc *sc = device_private(self); ... task_drain(); KASSERT(sc->sc_contrivedtask == NULL); task_destroy(&sc->sc_task); ... } static void mydev_intr(void *arg) { struct mydev_softc *sc = arg; ... /* If the hardware says there's stuff to do, schedule our task. */ mutex_enter(&sc->sc_lock); if (ISSET(intrmask, MYDEV_A_NEW_DEVELOPMENT)) { sc->sc_dostuff |= __SHIFTOUT(intrmask, MYDEV_STUFF); task_schedule(&sc->sc_task); } mutex_exit(&sc->sc_lock); ... } static void mydev_action(struct task *task) { struct mydev_softc *sc = container_of(task, struct mydev_softc, sc_task); uint32_t stuff = 0; /* Grab the stuff to do and acknowledge we're doing it. */ mutex_enter(&sc->sc_lock); if (sc->sc_dostuff) { doit = sc->sc_dostuff; sc->sc_dostuff = 0; } mutex_exit(&sc->sc_lock); /* Do it. */ for (i = 0; i < MYDEV_NSTUFF; i++) if (ISSET(stuff, (1U << i))) ... } static void mydev_doit(struct mydev_softc *sc) { ... /* Set up a task, if we need one. */ struct task *tmp = kmem_alloc(sizeof(*task), KM_SLEEP); mutex_enter(&sc->sc_lock); if (sc->sc_contrivedtask == NULL) { sc->sc_contrivedtask = tmp; tmp = NULL; task_init(sc->sc_contrivedtask, &mydev_contrivedtask); task_schedule(sc->sc_contrivedtask); } mutex_exit(&sc->sc_lock); if (tmp != NULL) kmem_free(tmp, sizeof(*tmp)); ... } static void mydev_nevermind(struct mydev_softc *sc) { struct task *task = NULL; /* Cancel the task, if there is one. */ mutex_enter(&sc->sc_lock); if (sc->sc_curtask != NULL) { if (task_cancel(sc->sc_curtask, &sc->sc_lock)) { /* We cancelled it, so we have to clean it up. */ task = sc->sc_curtask; sc->sc_curtask = NULL; } } mutex_exit(&sc->sc_lock); if (task != NULL) { task_destroy(task); kmem_free(task, sizeof(*task)); } } static void mydev_contrivedaction(struct task *task) { ... mutex_enter(&sc->sc_lock); KASSERT(sc->sc_contrivedtask == task); sc->sc_contrivedtask = NULL; mutex_exit(&sc->sc_lock); task_done(task); task_destroy(task); kmem_free(task, sizeof(*task)); }
March 27, 2014 | NetBSD 6.1_RC3 |