DELAYED_TASK(9) | Kernel Developer's Manual | DELAYED_TASK(9) |
void
delayed_task_init(struct delayed_task *dt, void (*fn)(struct delayed_task *));
void
delayed_task_destroy(struct delayed_task *dt);
void
delayed_task_schedule(struct delayed_task *dt, nsec_t nsec, jitter_t jitter);
bool
delayed_task_reschedule(struct delayed_task *dt, nsec_t nsec, jitter_t jitter);
bool
delayed_task_timedout(struct delayed_task *dt);
void
delayed_task_done(struct delayed_task *dt);
bool
delayed_task_cancel(struct delayed_task *dt, kmutex_t *interlock);
bool
delayed_task_cancel_async(struct delayed_task *dt);
Delayed tasks are very similar to task(9) tasks, about which see notes there for rules on what the actions may do.
Task state is stored in the struct delayed_task structure. Callers of the delayed_task abstraction must allocate memory for struct delayed_task objects, but should consider them opaque, and should not inspect or copy them. Each delayed task represented by a struct delayed_task object will be run only once at a time, until the action associated with it returns or calls delayed_task_done() to signal that it may be reused.
delayed_task_init() may be used in any context, including hard interrupt context.
delayed_task_destroy() may be used in any context, including hard interrupt context.
delayed_task_schedule() may be used in any context, including hard interrupt context.
delayed_task_reschedule() may be used in any context, including hard interrupt context.
delayed_task_timedout() may be called only by a delayed task's action.
delayed_task_done() may be called only by a delayed task's action.
The interlock is provided so that if the delayed task's action needs it and the caller of delayed_task_cancel() holds it, then delayed_task_cancel() can release the interlock after acquiring locks internal to the delayed_task abstraction in order to avoid racing or deadlocking with the delayed task's action. You should always assume that interlock will be released and re-acquired, and recheck any invariants you rely on it to preserve.
task_cancel_async() may be used in any context, including hard interrupt context.
struct mydev_softc { ... kmutex_t sc_lock; struct mydev_req *sc_req; struct delayed_task sc_timeout_task; ... }; static int mydev_submit_request(struct mydev_softc *sc, struct mydev_req *req) { int error; mutex_enter(&sc->sc_lock); if (sc->sc_req != NULL) { error = EBUSY; } else { ...write hardware registers to submit request... sc->sc_req = req; delayed_task_schedule(&sc->sc_timeout_task, mstons(1000), mstons(10)); error = 0; } mutex_exit(&sc->sc_lock); return error; } static void mydev_intr(void *arg) { struct mydev_softc *sc = arg; mutex_enter(&sc->sc_lock); if (!delayed_task_reschedule(&sc->sc_timeout_task, 0, 0)) { /* Too late -- timed out already. */ ...write hardware registers to rescind the request... } mutex_exit(&sc->sc_lock); } static void mydev_timeout_task(struct delayed_task *dt) { struct mydev_softc *sc = container_of(dt, struct mydev_softc, sc_timeout_task); mutex_enter(&sc->sc_lock); if (delayed_task_timedout(dt)) { mydev_req_timeout(sc->sc_req); } else { ...read/write hardware registers to get/ack the response... mydev_req_response(sc->sc_req, response); } mutex_exit(&sc->sc_lock); }
March 27, 2014 | NetBSD 6.1_RC3 |